Minimum requirements for new React Native item